answerstu

How to add the "Windows.Web.Http" to your project?

I am in the process of changing my Windows 8.1 store application to use TLS 1.2. This was required by the client who recently moved all Web APIs to HTTPS and forced the entire traffic network to use TLS 1.2. My store app started having communication issues with the Web API and the reason is that it is not forcing its calls to the Web API to use TLS 1.2. After some research, I saw that the System.Net.Http classes I used for the communication (HttpClient and HttpClientHandler) are not going to help me. I need to use similar API from Windows.Web.H...Read more

Can I use a Windows 8.1 API in Windows Embedded 8 Standard?

I am trying to make an embedded music device.There is already an existing music API I would like to use which has support for Windows 8.1 (not embedded). I am trying to figure out if there is a way for me to leverage the existing 8.1 music API with what Windows offers in its embedded solutions. Because it is a music device, it needs to be as real-time as possible. I realize there is the Windows Embedded Compact edition, but I don't believe I would be able to use a Windows 8.1 SDK in this environment. Am I right?Would I be able to use the 8.1 mu...Read more

How to set the default resolution in windows 8.1 winjs app

I'm working on my first winjs app for windows 8.1. So I'm a newbie in this topic, so please forgive me if I ask something obvious.My problem is the resolution of the target machine (DELL Latitude E7440 with touch screen) is 1920x1080, but when I run the app, it runs in 1370x771. Which is a bit confusing for me.So my question is, how can I tell the app to run in the same resolution as the OS runs.Strange thing I discovered: If I set the "Change the size of apps text, and other items on the screen (...)" settings from larger to default in the di...Read more

How to use virtualization on guest VM (windows 8.1) in virtualbox which is on a virtualization enabled CPU running Windows 7?

I have a 16GB laptop running on Intel core i7 processor. I have Windows 7 Enterprises installed on this machine. Now, I need to do some work around the Windows 8.1 Pro and need to run the emulator on Windows 8.1 Pro.So, I have installed the virtualbox on my machine and installed the Windows 8.1 Pro on a VM in virtualbox.I have enabled the Virtualization on my machine using the BIOS settings, but it is not reflected in the Windows 8.1 VM. And I have to enable the Hyper-V Platform from windows features for running the emulator, but it is not poss...Read more

windows 8.1 - YumRepo Error: All mirror URLs are not using ftp, http[s] or file

I have set up a centOS 6.5 server using VMWare Workstation 9 on a Windows 8.1 host laptop. When trying to use yum to install packages I get the following error:[root@localhost ~]# yum updateLoaded plugins: fastestmirrorLoading mirror speeds from cached hostfileYumRepo Error: All mirror URLs are not using ftp, http[s] or file. Eg. </html>/removing mirrorlist with no valid mirrors: /var/cache/yum/i386/6/base/mirrorlist.txtError: Cannot find a valid baseurl for repo: baseThe VM works on other machines (Windows 7 desktop and an Windows 8.1 l...Read more

windows 8.1 - Getting error: The smart card requires drivers that are not present on this system

All, I am getting an error when trying to login with my smart card to a hyper-v guest: "The smart card requires drivers that are not present on this system."Any Ideas?I am trying to use my smart card on a Hyper-V guest -Running Windows 8.1 -Microsoft image -Joined to the domain -I don't see a smart card reader in device manager, but not sure if I should in Hyper-V GuestWith a host -Running 8.1 -Not joined to the domain -With integrated card reader -With TPM enabled -The smart card reader appears in device manager and has the latest driver -The...Read more

Windows Explorer Not Reading ID3 Meta Tags for Custom File Type

I created a custom binary file type with its own extension (.atef).To provide some meta data about the file, I decided to implements the ID3 meta tags standard.I hoped that Windows Explorer in Windows 8 would automatically detect the existence of the standard ID3 meta tags and automatically fill the appropriate columns with the right data. In this case I make use of the "Title" and "Album Artist" properties. This is unfortunately not the case.If I rename any of my custom .ATEF file to .MP3, the meta information are read and shown properly as I ...Read more

Windows 8.1 Emulator does not exist

I have a Windows 8.1 Pro 64bit installed with Visual Studio 2013 Update 4.I tried to deploy the app on my device and it was successful. Yesterday, i tried to run the app on emulator and facing some problems.I downloaded the emulator from Windows Phone 8.1 Update and EmulatorDownload contains two files. I tried to install the SDK & Emulation images and setup completed without any problem.Now visual studio is showing the list of emulators in IDE but whenever i tried to run the app using emulator, VS gave me error as C:\Program Files (x86)\Mic...Read more

Error running windows phone emulator. Error 0x80131500

I have installed windows 8.1 on my macbook pro (Mavericks OS). I am trying to run a windows phone emulator on it. I am getting in the visual studio 2012 console.1>------ Deploy started: Project: PhoneApp1, Configuration: Debug Any CPU ------1>Deploying C:\Users\yyyyy\documents\visual studio 2012\Projects\PhoneApp1\PhoneApp1\Bin\Debug\PhoneApp1_Debug_AnyCPU.xap...1>Connecting to Emulator 8.0 Update 3 720P...1>Deployment of application to device failed.1>0x80131500========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========Can an...Read more

windows 8.1 - Use Mobile Broadband API for getting location details

Can I get cellID, LAC, MNC and MCC by using Mobile Broadband API in Windows 8? I have a Windows 7 Location application which opens SIM serial port and gets the cellID, LAC, MNC and MCC details and sends those details to unwired API and gets location details. So I am trying to replicate the same using Mobile Broadband API as we should not be opening ports.please help.Thanks in Advance!...Read more

windows 8.1 - Ubuntu server on virtualbox

I made virtual machine with ubuntu 14.04 on it and made in automatically boot with Windows 8.1 using Task Scheduler with these settings : Run whether user is logged on or notRun With highest privilegesHidden Triggers at startupAction is set to start a bat file with code "C:\Program Files\Oracle\VirtualBox\VBoxHeadless.exe" -s "Ubuntu"And i've set it to not automatically stop it.So everything is working fine. Apache server starts everything works. Then after a while it doesn't respond like it's been turned off, but the process VBoxHeadless.ex...Read more

DYMO Label cut-off print on Windows 8.1 and Windows 10

We have encountered a cut-off print issue with DYMO LabelWriter 450 Turbo after we have upgraded to Windows 10. After some investigation we found out that the same issue can occur on some of Windows 8.1 machines as well. We use DYMO.Label.Framework in our program.We have the following investigation results for now:Labels are printed correct via DYMO App v8.5.1.1816Labels with long barcodes or long lines are cut-off, there’s just a half of them is printedIt works if we build the app with .NET framework 3.5It doesn’t work if we build the app with...Read more