answerstu

windows 10 - AutoHotkey getting control key stuck

I have several situations when my control key gets stuck, and it happens only when I have AutoHotkey running. This happens with multiple different modifier keys (# (windows) key, ! (alt) key especially). Similar problems have been posted several times before: 1, 2, 3. Some solutions exists, and the one suggested here partially helped me (decreased the frequently of the problem), but I still sometimes have control key stuck.I have two questions: Is it possible to prevent this problem? Is there a good way to have AutoHotkey fix this as soon as it...Read more

windows 10 - Disable automatic rescaling of BufferedImage in JDK9

I use a customised renderer for rescaling the screen for my 8 bit computer emulators that works nicely in pre Java 9 environments. In Java 9, it creates triangular distortions on the main screen when the JVM automatically resizes the screen to accommodate for different resolutions. It is most noticeable when scan lines are enabled in the emulator. I'm suspecting it has something to do with this ==> http://openjdk.java.net/jeps/263 being delivered in Java 9.As an example, the effect can be seen when executing the following program on a 4K mon...Read more

delphi xe2 - How to activate window of other application

I have HTTP server application (service application that is ran as desktop application) that runs other application and later one should activate window of yet another application. Computer X contains all applications. When I run http://192.168.16.21:225/command/TTaskType.ttTestTask from Opera web browser from computer X, my WinActivate function works. When I run http://192.168.16.21:225/command/TTaskType.ttTestTask from computer Y, window is not activated. None debug outputs returns errors (I get FLastErrorY printed). I even tried to run HTTP ...Read more

Windows 10 Mobile Error: DEP6200

I am trying to deploy a Windows 10 app to a Lumia 635 running 10.0.10586.11 and I get this error: Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device 'DEVICE GUID'.': SEHException - External component has thrown an exception. Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found. The data necessary to complete this operation is not yet available.Unlike most, I am capable of deploying to an Emulator, just not the physical device. Based on this question: Error : DEP6...Read more

How to automatically run a third party Windows 10 Store App on Windows-Start-Up after log in

What I want to achieve is: To run a third party Windows 10 Store App, after a user logged in into his Windows 10.I've discovered already how to start “Bing News” Store app at start up after user logged in 3 steps. Thanks to instantfundas.Shortly explained the 3 steps:1: Locate in Windows Registry - HKEY_CURRENT_USER\Software\Classes[app-name]and check if it contains a “URL Protocol” in the format “URL:appname”.for example: HKEY_CURRENT_USER\Software\Classes\bingnews2: Create a Shortcut on the desktop to that app: %windir%\System32\cmd.exe /c st...Read more

windows 10 - Listbox keeps repeating first items

I have a simple listbox that loads items (in my test case 135). I logged all the ID's of the items that are loaded, and they all have a unique ID. The listbox datatemplate is a usercontrol, so in the usercontrol I also logged the ID's to see which ones are loaded.Now is where it starts going wrong, it only loads about the first 10 items (I think whatever is initially visible), and then keeps repeating those first items over and over again. So instead of 135 unique objects, I have 135 objects that are one of the first 10 or so loaded.You can see...Read more

windows 10 - UWP app on Xbox

During the events and promotions around Windows 10, I always see that the UWP apps can run on all devices from Microsoft family.To confirm that, when I am browsing for UWP apps on my browser and I click to see the source code from an app page, I am able to see the following meta data:<meta name="description" content="Download this app from Microsoft Store for Windows Phone 10, Windows 10, Surface HUB, HoloLens, other Windows devices, Xbox. See screenshots, read the latest customer reviews, and compare ratings. " />So why I can't see these...Read more

Retrieving and editing photo 'tags' in Windows 10 UWP app

I am trying to access (and eventually edit) the tags stored on files in Windows to drive some logic within my UWP Windows 10 app. var storageFile = await StorageFile.GetFileFromPathAsync(Path.ToString());var imageProperties = await storageFile.Properties.GetImagePropertiesAsync();This returns the following:Camera ManufacturerCamera ModelDateTakenHeight / WidthKeywords (System.__ComObject)Lat / LongOrientationRatingPeople Names (System.__ComObject)While this is useful it doesn't help. Maybe 'keywords' is the right one but when I look at the imag...Read more

windows 10 - The local machine's clock may be out of sync with the server time by more than five minutes

While configuring VSTS agent locally through command prompt with admin privileges, i've encountered the error below The local machine's clock may be out of sync with the server time by more than five minutes. Please sync your clock with your domain or internet time and try againI've tried different google answers but nothing worked out. Please help me...Read more

windows 10 - How to hide my app's calendar from built-in calendar app?

My app needs an internal calendar. I can create a new calendar like this:var store = await AppointmentManager.RequestStoreAsync(AppointmentStoreAccessType.AppCalendarsReadWrite);var cacheCalendar = await store.CreateAppointmentCalendarAsync("unique name here");This succeeds and I get a new calendar. But this calendar is visible in the phone's built-in calendar app. I don't want this calendar to be visible since it's for internal bookkeeping. So I try to hide the calendar like this:var store = await AppointmentManager.RequestStoreAsync(Appointme...Read more

windows 10 - UWP apps accessing files from random location on system

in UWP there are files and permissions restrictions, so we can only acces files directly from few folders or we can use filepicker to access from anywhere on system.how can I use the files picked from filepicker and use them anytime again when the app runs ? tried to use them again by path but it gives permission error. I know about the "futureacceslist" but its limit is 1000 and also it will make the app slow if I am not wrong? .Is there a better way to do this ? or can we store storage files link somehow in local sqlite database?...Read more

wifi - Triggering Network Flyout/Toast UI via command in Windows 10

I'm looking for a way to trigger the WiFi menu shown on the taskbar (typically a black bar with available networks. NOT the Settings app). I've been looking for a command of sorts that could potentially be run through something like a batch file but have come up dry.I have found lists of commands, like the one below, through which you could open the list of networks in the Settings app but unfortunately that's not what I'm after (I'd like to minimise the menu items an end user has access to):https://www.neowin.net/news/psa-how-to-open-specific-...Read more

windows 10 - How to get information about UWP app?

How can I get information about an UWP application on Windows 10 from another application?As a minimum, I am interested in application name and default tile. Then, I would like to be able to learn as much as possible, of course.Some UWP apps can be linked to an EXE. That is, their main window is created by an EXE. This helps. At least, I know the location of "resource.pri", which presumably can be read.But, there are apps which do not have EXE, and "hosted" by wwahost.exe instead. These are black boxes to me. Is there any way to know what is in...Read more

windows 10 - Cannot load file or assembly Microsoft.MSXML version 8.0

What started the issue: My internet had dropped on the 5g band so I began trouble shooting to get the IP back. I saw that my non 5g band was valid and clicked connect on that WiFi connection to just get the internet back up quickly. Once I clicked connect, windows 10 locked up and blue screen shortly after. The OS started back up just fine but when I recovered my unsaved Visual Studios project, it seemed like things were corrupted at first glance, but it wasn't, everyone of my Visual studios projects load just fine, but when I click on a C++ or...Read more