answerstu

mount - qnx6 fs cannot be mounted read/write, standard hd

I am running Neutrino 6.4.0 with an attached standard 2.5" , 250GB Toshiba hard disk with 6 pre-existing qnx6 partitions. All of them can be mounted read-only; however, I cannot mount any of those as read/write. For instance:mount -r -t qnx6 /dev/hd1t77.3 /home/p3works fine, while mount -t qnx6 /dev/hd1t77.3 /home/p3returns the following:mount: Can't mount /home/p3 (type qnx6)mount: Possible reason: Read-only file systemI have even tried different sync options (-o sync=ignore , and -o sync=optional), to no avail.Interestingly, I have created an...Read more

mount - Transport endpoint is not connected

FUSE is constantly(every 2 - 3 days) giving me this Transport endpoint is not connected error on my mount point and the only thing that seems to fix it is rebooting. I currently have my mount points setup like this, I'm not sure what other details I should add here so let me know if I missed anything../dev/sdc1 /mnt/hdd2 ext4 defaults 0 0/dev/sdb1 /mnt/hdd1 ext4 defaults 0 0mhddfs#/mnt/hdd1,/mnt/hdd2 /data fuse defaults,allow_other 0 0...Read more

mount - S3FS inside LXC containers mounted by the host

I'm currently using several LXC containers to isolate other users' programs from the host system. The rootfs of each container uses a union file system and a few mount-binds from the host and everything is working correctly.Now I want to be able to use S3FS to mount an S3 bucket on the host and mount-bind it into a directory on the rootfs of each container. It needs to be mounted by the host because I don't want any of the users in the container to see the aws secret key. This appears to work fine (I am able to see the files in the s3fs mount i...Read more

mount - How can I ensure that a "bind" filesystem is mounted after its parent filesystem?

I have recently added a couple of entries to my fstab to allow me to rebind some directories to elsewhere in my filesystem tree, like this/mnt/smb/foo/bar /home/mishagale/sourcecode/bar bind defaults,bind 0 0However, /mnt/smb/foo happens to be an SMB filesystem (on a Samba server), with a line earlier in fstab that looks like//192.168.1.7/foo/ /mnt/smb/foo smbfs uid=1000,gid=1000,rw,auto,user,user=myuser,pass=mypass 0 0(obviously, these lines have been anonymised)The problem is, now I get an error at boot time "The disc drive for /home/mishagal...Read more

archlinux - Udisk - Error creating mount point no such file or directory

I'm trying to automatically mount a USB drive on linux. With all default settings it works and the drive is mounted to /run/media/username/drivename.I tried to change the default mount point to /media/drivename by following the guide linked here: https://wiki.archlinux.org/index.php/Udisks#Mount_to_/media_(udisks2)I added the file /etc/udev/rules.d/99-udisks2.rules with the following contents:# UDISKS_FILESYSTEM_SHARED# ==1: mount filesystem to a shared directory (/media/VolumeName)# ==0: mount filesystem to a private directory (/run/media/$USE...Read more

mount - What does cifs_mount failed w/return code = -22 indicate

I am tryingsudo mount -t cifs //<server>/<share> -o username=user@domain,password=**** /mnt/<mountpoint>error message: mount: wrong fs type, bad option, bad superblock on //server/share, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or soThe syslog has CIFS VFS: cifs_mount failed w/return code = -22I am able to mount the same share on another centos system. I can ping the server, mount point directory has been created....Read more

mount - deal with an improperly unmounted disk

I didn't properly unmount a new external disk which I mounted like:jeremy@jr:~$ sudo mount -t exfat /dev/sdc1 /home/jeremy/exfatFUSE exfat 1.2.3and now I am stuck - jeremy@jr:~$ df -hdf: /home/jeremy/exfat: Transport endpoint is not connectedFilesystem Size Used Avail Use% Mounted onudev 3.8G 0 3.8G 0% /devtmpfs 765M 9.5M 756M 2% /run/dev/sda1 213G 200G 2.1G 100% /tmpfs 3.8G 165M 3.6G 5% /dev/shmtmpfs 5.0M 4.0K 5.0M 1% /run/locktmpfs 3.8G 0 3.8G 0% /sys/...Read more

mount - pam_mount + sshfs + port != 22

How can i configure my volume in ~/.pam_mount.conf.xml so set a different port for ssh?Currently, default (using port 22) this works:<volume options="nosuid,nodev" user="yourUsername" mountpoint="~/mountpoint" path="sshfs#%(USER)@server:" fstype="fuse" />Thanks for hints. G. does help and manpage shows not the right way for me to find out.Kind regards flobee...Read more

mount - How to specify base directory for FUSE filesystem?

I am trying to create a FUSE filesystem called ordered-dirs using the Haskell wrapper over libfuse, HFuse. This filesystem is a "derived filesystem", i.e. it takes an existing directory (the "base directory") and produces a different view of it.However, when I try to run my FUSE filesystem program, specifying the arguments in the ordinary mount way, I get an error:$ ordered-dirs /home/robin/tasks/ /home/robin/tofuse: invalid argument `/home/robin/to'There is no way in HFuse (or in libfuse, it seems) to get the base directory (the first argument...Read more

mount - Mounting a file system using a C program

In my initramfs.cpio I have only these directories:root@localhost extract]# ls dev init tmp sys dev has console and sys is empty. init is a binary corresponding to program that I discussed in Accessing GPIO after kernel boots.Now in the same GPIO program I would like to write code to mount a /sys. I understand it can be mounted using mount:mount -t sysfs none /sysHow do I write a C program that will implement the above line. Please note that I do not have a file system; initramfs.cpio has empty folders: /sys, /tmp. I can put more empty folde...Read more

mount - How to mask a folder name differently to WSL?

I am using Microsoft's OneDrive for Business provided by our university to sync big junks of data. I'm also using using a software to run some simulations which is not available for windows and I have to use WSL. Now the issue is that OneDrive folder name is like OneDrive - University of foobar and the software I'm using refuses to accept path names with spaces in it. Unfortunately as far as I know Microsoft has made it impossible to change the folder name for OneDrive for business. I have to find a way to fool WSL to think the folder name is d...Read more

mount synology NAS

I am on Ubuntu 14.04 and I am trying to mount a synology NAS.I have followed all indications on https://www.synology.com/en-us/knowledgebase/DSM/tutorial/File_Sharing/How_to_access_files_on_Synology_NAS_within_the_local_network_NFSHowever I still get the error message when trying to mount the disk: sudo mount 192.168.0.3:/volume1/video /mnt mount: wrong fs type, bad option, bad superblock on 192.168.0.3:/volume1/video, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might ...Read more

dd - How to create and mount file for read and write as a HFS+ filesystem in linux?

I am trying to mount a file that will act as a read/write HFS+ filesystem. I am using arch linux based distro so I installed hfsprogs and hfsutils. In debian based distros hfsprogs should be enough.I created a 8G file like this:dd if=/dev/zero of=test.img bs=1024 count=0 seek=$[1000*8000]Then I did the formatting:mkfs.hfsplus -v TestImg test.imgAfter that when I try to mount the file I get:mkdir /tmp/sunsudo mount -t hfsplus -o loop,rw,offset=0 test.img /tmp/sunmount: /tmp/sun: mount failed: Operation not permittedParted shows that offset it ok...Read more