answerstu

azure artifacts - VSTS CI NuGet push to private feed success but doesn't show anything

I have a solution building as part of continuous integration, with a step to push a class library out to my VSTS package feed. This worked the first time the CI build ran and created the package. The second time it shows it was successful, but a new version doesn't exist or any sign of a new package.Prior to the second build, I promoted the package to @release, if that makes a difference?Output of the CI build for NuGet push is below:2017-07-24T10:48:51.4888942Z ##[section]Starting: NuGet push2017-07-24T10:48:51.4888942Z =======================...Read more

pnpm install fails with azure devops (vsts) private package feed

I have a private packages feed on Azure DevOps (formerly VSTS) with a few packages.I have a project configured (through .npmrc) to use that feed. vsts-npm-auth -config .npmrc (to configure auth for npm with the feed) completed with success.If I run npm install, the modules installation runs successfully.If I delete the node modules folder, the package lock and run pnpm install instead I get a 401 Unauthorized error.Computer is running windows 10 (latest public ring).My question is: how to configure pnpm to run properly with an azure devops priv...Read more

Use an external (private) nuget server as upstream source in Azure Artifacts?

Is there any way of using an external private nuget feed (either an Artifact feed belonging to another organization, or a standalone private (basic auth) enabled nugetserver) as an upstream source in Azure Artifacts? It is possible in other parts of Azure Devops as a service connection, but I can't find a way of either utilizing service connections nor specify a private external nuget as upstream source in Artifacts. The only options are public nuget servers and feeds present in Devops....Read more

azure artifacts - VSTS Nuget push: 400 (Bad Request)

I'm attempting to push to the Package portion of VSTS. I'm getting Bad Request back, but there's no further detail, which is very frustrating. Here is my request and the return.nuget push -Source "MFS" package.nupkg -Verbosity detailed -ApiKey VSTSNuGet Version: 3.5.0.1938Pushing package.nupkg to 'https://instance.pkgs.visualstudio.com/_packaging/c59817c1-a3c5-4654-95cf-760c1ce56c62/nuget/v2/'... PUT https://instance.pkgs.visualstudio.com/_packaging/c59817c1-a3c5-4654-95cf-760c1ce56c62/nuget/v2/ ...Read more